PocketWizard MiniTT1 and FlexTT5 Firmware Update Provides Support for Canon 5D Mark III

PocketWizard-MiniTT1-and-FlexTT5

PocketWizard has finally got theĀ MiniTT1 and FlexTT5 working with the 5D Mark III. You can download the update from PocketWizard’s website.

Next on PocketWizard’s list is getting support up and running for the Canon 1D X.

Prioritized rolling BETA release plan for MiniTT1 and FlexTT5 Firmware:

1) MiniTT1/FlexTT5 BETA firmware release for Canon
Compatibility with the following CANON gear:
1. Canon 1D X Camera*

2) MiniTT1/FlexTT5 Beta firmware release for Nikon
Compatibility with the following NIKON gear:
1. Nikon D600 & Nikon D3200

3) MiniTT1/FlexTT5 Beta firmware release for Canon
Compatibility with the following CANON gear:
1. Canon T4i & Canon 6D

email